Tremendous - Delays in email delivery – Incident details

Delays in email delivery

Resolved
Degraded performance
Started 2 months agoLasted about 8 hours

Affected

API
Dashboard
Updates
  • Resolved
    Resolved

    We are seeing emails delivered immediately at this point.

  • Monitoring
    Monitoring

    The service provider we use for email delivery, SendGrid, is experiencing an incident that is causing delays in email delivery. This can affect all emails we send, including reward deliveries and transactional emails such as login verification emails. SendGrid is assuring us that no email is lost, but this is currently causing significant delays in emails being delivered.

    We are monitoring the SendGrid incident and will verify that emails are delivered correctly.