Degraded performance with background processing framework

Resolved
Degraded performance
Started about 2 years ago Lasted 43 minutes

Affected

API
Reward redemptions
Dashboard
Updates
  • Resolved
    Resolved

    This issue is now resolved and all background tasks are being picked up quickly again.

  • Monitoring
    Monitoring

    Fix has been implemented. Things are steadily going back to normal- we're monitoring to make sure all stays well.

  • Identified
    Identified

    Our background processing framework is processing tasks too slowly. This is resulting in lag for things like sending reward emails, webhooks going out, and new orders / rewards showing up in search bars. It appears to have started yesterday. Engineers have identified the issue and are working on a fix.