Redemptions to PayPal and Venmo are delayed

Resolved
Degraded performance
Started 2 months ago Lasted about 10 hours

Affected

Reward redemptions
Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Update

    New payouts are no longer being delayed and we have started to clear the queue of delayed payouts.

  • Monitoring
    Monitoring

    Redemptions to PayPal and Venmo are currently delayed. We expect to pay out delayed redemptions starting at 11am ET today.