Tremendous - Fulfillment delays for USA gift cards – Incident details

Reward redemptions experiencing degraded performance

Fulfillment delays for USA gift cards

Monitoring
Degraded performance
Started about 6 hours ago

Affected

Reward redemptions

Degraded performance from 12:00 PM to 12:00 AM

Updates
  • Monitoring
    UTC
    Monitoring

    The vendor seems to have fixed the issue on their end and fulfillments are going through normally. We'll continue monitoring to ensure continued stability.

  • Investigating
    UTC
    Investigating

    Due to issues with an upstream provider, USA gift cards are experiencing fulfillment delays. We're already in contact with the vendor to investigate.