SMS delivery issues

Resolved
Degraded performance
Started 9 months ago Lasted about 22 hours

Affected

Reward redemptions
Dashboard
Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Investigating
    Update

    We have mitigated this issue by sending messages from a new number. New messages are now being delivered successfully. We have re-sent all rewards that failed to be delivered because of this issue.

  • Investigating
    Investigating

    According to our SMS provider, T-Mobile is currently filtering out our SMS messages. This means that a fraction of our application's text messages are not going through. This is affecting 2-factor authentication and SMS reward delivery. We've escalated the issue to the carrier, and are also looking at alternative options. But in the meanwhile, these messages are being dropped.