Tremendous - API incorrectly rejecting some new orders – Incident details

API incorrectly rejecting some new orders

Resolved
Partial outage
Started about 2 months agoLasted about 3 hours

Affected

API

Partial outage from 10:42 AM to 1:36 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Identified

    Over the past year we have been gradually and methodically migrating customers away from the usage of multi-reward orders. Today, we added a new validation to ensure that no new customers could start using multi-reward orders.

    Unfortunately there was a bug in our validation and we started rejecting create order payloads that contained only one reward, but did so in an array under the rewards key rather than the singular reward key. This was not intentional, and orders using that format continue to be valid today and into the future.

    Any order affected by this issue would have received a 422 response with the error message "Send data for a single reward in the reward field"

    This affected orders placed between 10:28 and 13:36 UTC (that's 6:42am to 9:36am ET). We apologize profusely for this issue. We are implementing additional tests and monitors to ensure this doesn't happen again.

    None of the affected orders were placed in our system; please retry them now and they should succeed.