Tremendous - Fulfillment errors for Amazon.com, Visa Cards and other 100+ products – Incident details

Fulfillment errors for Amazon.com, Visa Cards and other 100+ products

Resolved
Major outage
Started about 2 months agoLasted about 3 hours

Affected

Reward redemptions

Operational from 12:18 PM to 12:48 PM, Major outage from 12:48 PM to 1:22 PM, Partial outage from 1:22 PM to 3:12 PM

Updates
  • Resolved
    Resolved

    Prepaid card issues seem to have subsided, but we are continuing to monitor for new issues.

  • Identified
    Update

    Vendor APIs seem to be coming back online now, and fulfillment is slowly resuming back to normal.

  • Identified
    Update

    We're seeing progress from our upstream vendors. Though gift card fulfillment isn't working yet, their APIs seem to be coming online again.

  • Identified
    Identified

    Our best guess is that this is related to the Crowdstrike global outage, given it's affecting multiple gift card fulfillment vendors that we rely on.

  • Investigating
    Investigating

    Due to internal issues with an upstream fulfillment provider, redemptions for 100+ gift cards in the US are experiencing errors, including brands like Amazon, Walmart, Target, Starbucks.
    We are monitoring the product status with the fulfillment provider and should have redemption become available again soon.