Tremendous - Delays in processing PayPal and Venmo payouts – Incident details
All systems operational
Delays in processing PayPal and Venmo payouts
Resolved
Degraded performance
Started over 1 year agoLasted about 4 hours
Affected
Reward redemptions
Degraded performance from 3:28 PM to 7:19 PM
Updates
Resolved
Resolved
This incident has been resolved.
Identified
Identified
We're experiencing delays in processing PayPal and Venmo payouts. We're working to get these processed with our payment partners as soon as possible, and will report back with updates.