Tremendous - Database degraded performance – Incident details

Database degraded performance

Resolved
Degraded performance
Started almost 3 years agoLasted about 4 hours

Affected

API

Degraded performance from 6:35 PM to 10:27 PM

Reward redemptions

Degraded performance from 6:35 PM to 10:27 PM

Dashboard

Degraded performance from 6:35 PM to 10:27 PM

Updates
  • Resolved
    Resolved

    Incident has been resolved, all systems back to normal.

  • Monitoring
    Update

    All systems appear to be operational now. We are still monitoring some delays in our background processing systems, but there should be minimal impact on component performance.

  • Monitoring
    Monitoring

    We've deployed a fix and are monitoring improvements. Performance issues are starting to dissipate, and should be fully back to normal within a few hours.

  • Identified
    Identified

    We're investigating degraded app performance resulting in longer response times and some timeouts. Engineers have identified the root cause and are working to resolve.