Tremendous - Redemptions to PayPal and Venmo products are delayed until Feb 20th – Incident details
All systems operational
Redemptions to PayPal and Venmo products are delayed until Feb 20th
Resolved
Degraded performance
Started 8 months agoLasted about 12 hours
Affected
Reward redemptions
Degraded performance from 12:18 PM to 12:44 AM
Updates
Resolved
Resolved
We were able to clear the delayed PayPal and Venmo payouts early. All delayed payouts have been completed at this point, and new redemptions are no longer delayed.
Identified
Identified
Users will be notified as soon as their reward is available.