Tremendous - PayPal and Venmo redemption delays – Incident details
Report an issue
Get updates
Email
Slack
Microsoft Teams
Google Chat
Webhook
RSS
Atom
API
Report an issue
Get updates
All systems operational
PayPal and Venmo redemption delays
Resolved
Degraded performance
Started 12 days ago
Lasted 32 minutes
Affected
Reward redemptions
Operational from 9:19 PM to 9:52 PM
Updates
Resolved
April 08, 2025 at 9:52 PM
Resolved
April 08, 2025 at 9:52 PM
This incident has been resolved.
Monitoring
April 08, 2025 at 9:19 PM
Monitoring
April 08, 2025 at 9:19 PM
We are monitoring the situation.