Tremendous - Delays with physical and digital prepaid cards – Incident details

Delays with physical and digital prepaid cards

Resolved
Degraded performance
Started 3 days agoLasted about 7 hours

Affected

API

Degraded performance from 2:32 PM to 9:37 PM

Reward redemptions

Degraded performance from 2:32 PM to 9:37 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Identified

    A small portion of physical and digital prepaid cards are experiencing delays, preventing order placement and some cards from being displayed. The problem has been identified and we are working with our vendor to resolve this issue.