Tremendous - Issues with Venmo redemptions – Incident details
All systems operational
Issues with Venmo redemptions
Resolved
Degraded performance
Started 1 day agoLasted 1 day
Affected
Reward redemptions
Degraded performance from 4:10 AM to 5:38 PM
Updates
Resolved
Resolved
We've confirmed new payouts work correctly. We're marking this incident as resolved, but we're still working on refunding affected recipients. We will communicate that resolution directly to the affected recipients.
Monitoring
Monitoring
Venmo has fixed the issue and we have released all delayed payouts. We are still working on refunding the incorrectly charged fees.
Identified
Identified
We're aware that Venmo is incorrectly charging recipients fees. We are delaying Venmo redemptions while we work to fix this issue. We are also working on a resolution for recipients who received less than the correct amount. We'll update this as soon as we know more.