Tremendous - Recipients unable to redeem – Incident details

Recipients unable to redeem

Resolved
Major outage
Started 4 days agoLasted about 1 hour

Affected

Reward redemptions

Major outage from 9:24 PM to 10:51 PM

Updates
  • Resolved
    Resolved

    We identified a change in our bot detection as the root cause for this incident, and have rolled back the change. We apologize for this incident. Recipients can now retry their redemption.

  • Identified
    Identified

    Recipients were unable to redeem their rewards during this timeframe.